SRC experiencing degraded performance
Incident Report for Shuttlerock
Resolved
The issue has resolved, and the SRC is working normally again.
Posted May 24, 2024 - 03:05 UTC
Investigating
We are currently investigating this issue, and will let you know when it is resolved.
Posted May 24, 2024 - 02:56 UTC
This incident affected: Shuttlerock Cloud (Order API, Order UI, Revision UI, Revision API).